Perhaps I spoke too soon

Just to make a point about how tricky it is to get a site design to work, I left a comment here to the following effect:

Layouts do funny things in lots of unpredictable ways. My comment box displays wrong in Safari for some reason.

On the off-chance that someone might ask what my definition of “wrong” might be, I then duly pulled up Safari and invoked the comment section here — which displayed correctly, although the comment-preview function doesn’t actually work unless the site cookie is set.

This is the new Safari 5, so maybe they fixed something. Certainly I didn’t fix anything.





7 comments

  1. canadienne »

    4 July 2010 · 6:55 pm

    I think the Safari 5 update fixed the problem, since the comment box was blocked on the left by the text on the right, on all the the Macs I’ve used.

  2. canadienne »

    4 July 2010 · 7:01 pm

    I think the Safari 5 update fixed the problem, since the comment box was blocked on the right by the text on the right hand column, on all the the Macs I’ve used anyway.

    Still has that problem in Firefox, even after the 3.6 upgrade.

  3. CGHill »

    4 July 2010 · 7:05 pm

    That would be my guess. I have tried it only on this one box, although I have Safari installed at work for test purposes. (I have to shove stuff up to the corporate site now and then.) And I have a lot of Safari users; the volume fluctuates, as it will, but both Analog (at server level) and SiteMeter (offsite) figure that about 20 percent of visitors to this domain are using Safari. I’ve felt bad about that comment bug, but obviously not bad enough to switch to another theme. :)

    Curiously, though, it’s always worked in Firefox.

  4. canadienne »

    4 July 2010 · 7:05 pm

    Oops. hit that twice – also have to say that your page loads very slowly in Safari 5 but faster in Firefox.

  5. CGHill »

    4 July 2010 · 7:08 pm

    I’ve never seen any particular speed consistency with any of the Big Three browsers. Firefox has sped up a bit of late; I’m hoping this means that Mozilla has cut down on the bloat somewhere. IE 8, I haven’t really tested enough to have an opinion on.

  6. ak4mc »

    5 July 2010 · 11:47 am

    I’m on Firefox 3.6.7 and I can’t recall ever having trouble with the comment box here — other than coming up with decent-quality content for it, but that’s not browser-specific.

  7. canadienne »

    5 July 2010 · 11:36 pm

    I have the quality-content bug too, but that has nothing to do with the site. For the record, looks just fine in both browsers in Snow Leopard (had problems with the older cat.)

RSS feed for comments on this post